account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Problems and bugs with KitKat 4.4.4 (14.4.A.0.155 and .157)

Highlighted
Enthusiast
Message 1 of 167
15,685 Views
Message 1 of 167

Problems and bugs with KitKat 4.4.4 (14.4.A.0.155 and .157)

So let's start with KitKat 4.4.4 bugs.

 

There is still a problem with adding a photo to a contact - problem I have reported here.

This bug has been partly fixed in 4.4.4. Theres is no longer 7-10 sec waitng for starting app to crop a photo and if I choose taking a new photo everything is as should be.

Problem remains when I try to choose a photo from a photo album. Every photo is 90 degrees rotated, while cropping is still rotated and finally photo added to a contact is rotated.

 

This bug didn't exist in .681 firmware and previous ones.

166 REPLIES 166
Enthusiast
Message 2 of 167
15,611 Views
Message 2 of 167

Re: Problems and bugs with KitKat 4.4.4

Today I met my friend who has got a Xperia Z1 with the latest KitKat .108 firmware and he has the same bug I've described above.

Commissioner
Message 3 of 167
15,578 Views
Message 3 of 167

Re: Problems and bugs with KitKat 4.4.4

Strange. I don't have this issue. Did you try this in safe mode?

Enthusiast
Message 4 of 167
15,461 Views
Message 4 of 167

Re: Problems and bugs with KitKat 4.4.4

Safe mode?

On XDA forum there are people who have this bug and people who haven't. Maybe there are some differences between firmwares prepared for different regions of the world and some of them have this bug. I use Central Europe firmware, one of the guys from XDA forum uses Germany firmware and he doesn't expererience this bug.

Visitor
Message 5 of 167
15,516 Views
Message 5 of 167

Xperia Z1 Compact 4.4.4 Issues and Bugs

Hi there, I have already update my z1c to android 4.4.4 and currently  i dont see any bugs (as of now). But I am still exploring the phone itself. Hope I dont see any bugs later.

By the way Im from Philippines, and i already got that update everyone waiting for Slightly smiling Face

Inhabitant
Message 6 of 167
15,498 Views
Message 6 of 167

Re: Xperia Z1 Compact 4.4.4 Issues and Bugs

Nope, the bug of huge battery drain after connecting to Bluetooth MAP still there.....Sony is really hopeless!
Learner
Message 7 of 167
15,465 Views
Message 7 of 167

Re: Xperia Z1 Compact 4.4.4 Issues and Bugs

I updated to 4.4.4 in UK and everything is fine but if I use the camera after playing games or stressing the phone and it gets a bit warm, the camera app freezes, the focus square remains on the screen, it doesn't responds to the comands other then the block/unblock button and it doesn't saves the photo once I try to take it. I tried restarting the camera app, clearing app's data and force closing it without effect. Restarting the phone fixed the issue but I don't know if it's permanent. Other than that everything is perfect.
Apprentice
Message 8 of 167
15,414 Views
Message 8 of 167

Re: Xperia Z1 Compact 4.4.4 Issues and Bugs

The thumbnail duplication bug is still present in the album app.
Talent
Message 9 of 167
15,338 Views
Message 9 of 167

Re: Xperia Z1 Compact 4.4.4 Issues and Bugs

the problem is that the pictures you are trying to use for contacts have rotation/orientation data themselves

Message 10 of 167
15,264 Views
Message 10 of 167

Re: Problems and bugs with KitKat 4.4.4

I have a problem that gps no longer pin point my location. It's really annoying. I have tried several restart, came out of my home to check it but still the same. Before this update it was working fine inside of my home also. What could have been wrong? Tried disabling and enabling location, gps etc but no luck

I checked google+ where I was sharing location with my friend and there its showing my location of 3 hours ago. What went wrong in that 3 hours?

Don't ask me to repair my software and loose my data it will be annoying.