account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

No cellular signal after 5.0.2 update

Highlighted
Visitor
Message 1 of 5
314 Views
Message 1 of 5

No cellular signal after 5.0.2 update

After updating my Z2 (D6503) to Lollipop I got 'Invalid card' and no mobile signal, once in 1-2 days.

After rebooting the phone everything is fine but just for 1-2 days.

 

I've tired factory reset and pc companion repair but without success.

 

Z2

4 REPLIES 4
Moderator
Message 2 of 5
305 Views
Message 2 of 5

Re: No cellular signal after 5.0.2 update

I'd suggest getting a new SIM card replacement, especially if your card is self-cut into microSIM.



Feel free to kudo this post or mark it as solution so that other users facing the same issue can find it

Disclaimer: Moderators are not affiliated with or work for Sony Mobile, their posts represent their own opinions and views. Click here to find out more about the different roles in the community.

Visitor
Message 3 of 5
284 Views
Message 3 of 5

Re: No cellular signal after 5.0.2 update

I dont' think that it's sim card problem, because after restart it works fine.

If the sim card is somehow removed the phone will restart immediately.

Forum Legend
Message 4 of 5
280 Views
Message 4 of 5

Re: No cellular signal after 5.0.2 update

I have escalated this issue as a few members are reporting the same thing so for now we have no surefire way to fix the issue you and others have

For a successful technology, reality must take precedence over public relations, for Nature cannot be fooled.   Richard P. Feynman



Forum Legend
Message 5 of 5
252 Views
Message 5 of 5

Re: No cellular signal after 5.0.2 update

@Delicon from sony staff

 

I would ask the user to try:

- Switch network mode to check if it might be an issue with a certain network

- Try manually selecting the right network (it might already be set on manual causing issues)

- Check with the operator if they are aware of any network issue

- Try another SIM-card

- Repair the phones software

- If possible, try another operator

 

If the above fails then you would need to either return your device to the place of purchase or contact Xperia care and have your device inspected http://www.sonymobile.com/global-en/support/contact-us/

For a successful technology, reality must take precedence over public relations, for Nature cannot be fooled.   Richard P. Feynman