account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

MXTP issue

Adviser
Message 41 of 83
1,288 Views
Message 41 of 83

Re: MXTP and problem on C4 : Bug

I restarted in safe mode, I tried to repair the phone using pc companion, I did a factory reset... still the same !

apparently it is a problem with the new firmware since a lot of people are having this same problem after they updated their phones !

 

Sony should help us with that and provide a patch !

Sony Xperia Support
Message 42 of 83
1,269 Views
Message 42 of 83

Re: MXTP and problem on C4 : Bug

I'm very sorry to hear that Slightly frowning Face

Could you please send me a private message with the IMEI of your phone and i'll forward this internally for more information about what could cause this and how it can be solved.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Adviser
Message 43 of 83
1,258 Views
Message 43 of 83

Re: MXTP and problem on C4 : Bug

I've sent you my IMEI by msg

the problem seems to be with the latest firmware and MXTP, it happenned to a lot of users who made the update

Adviser
Message 44 of 83
1,250 Views
Message 44 of 83

Re: MXTP and problem on C4 : Bug

Finally solved my problem !
I flashed my phone with an older Official firmware ( the 27.1.a.1.106)

i could have access to MXTP authentification after that !

Sony shouldn't put firmware updates with bugs like this ! 

many people had to send their phones to the support service for that.

The bug is actually in the last update 27.2.A.0.155 ! 
if you have MyXperia activated, deactivate before upgrading or you will have the same problem again !

Learner
Message 45 of 83
1,234 Views
Message 45 of 83

Re: MXTP and problem on C4 : Bug

Hi zangetsuu!

 

Please, could you tell me how have you flashed the phone!? I have the same problem you had.. My Xperia Helper has stopped when tried to authenticate. I am in Argentina, and local support (Sony Argentina) can do nothing because the model is not in sell by Sony Argentina... unbelievable... Besides a sony technician told me flashing the phone could cause more problems and advised me to contact Sony USA where the phone was bought. I did it.. the asked me to send the phone to USA to repair.. because is still under warranty..

 

Could you tell me step by step how to solve this problem please!?

 

Thanks!

Learner
Message 46 of 83
1,226 Views
Message 46 of 83

Re: MXTP and problem on C4 : Bug

Dear Sony Xperia Support Team

 

I am having the same problem with my Xperia C4. When try to authenticate the device blocked under MXTP, appears the message My xperia has stopped.

 

What can i do.?? 

 

I am sending now a private message with my IMEI.

 

Thanks...

Adviser
Message 47 of 83
1,215 Views
Message 47 of 83

Re: MXTP and problem on C4 : Bug

The sure thing is that if you unlock your bootloader, you will lose your warranty, so don't do that.

but you can use sony Xperifirm to download any firmware older than the 27.2.A.0.155 for your phone ( with the exact model ) and flash it using Flashtool.

This won't damage your phone if you do it right. 

and even if it doesn't work, you'd still be able to use Sony Pc Companion to repair your phone and do a factory reset.

 

What I did is that I downloaded an older Firmware with the "Xperifirm" program ( the  27.1.A.1.106  version ), then I used Flashtool to flash my phone and downgraded it.

 

after that I was able to authenticate, and the "MyXperia Helper stopped" problem dissapeared.

 

Now my phone is ok.

right after that I deactivated the MyXperia , and I'm waiting for sony to provide for a new upgrafe with a fix for that problem , so i can update my phone again without being afraid of having the same problem

Visitor
Message 48 of 83
1,116 Views
Message 48 of 83

Re: MXTP and problem on C4 : Bug

Hello!!

I actually had this problem too!! And I trying to flash with flashtool but not working, can you tell me what version of Flashtool used it, and drivers necessary to windows identify the device in fastboot mode? Thank you a lot!!

 

Adviser
Message 49 of 83
1,095 Views
Message 49 of 83

Re: MXTP and problem on C4 : Bug

I used the last version of flashtool

and no need for fastboot, just flash it normally with flashmode ( and use the slower USB speed )

Visitor
Message 50 of 83
1,061 Views
Message 50 of 83

Re: MXTP and problem on C4 : Bug

Thanks so much Zangetsuu!!

 

Finally can recovered my cellphone, my mistake was the flashtool version, only downloaded the new version and woala works!!!

 

thank you for you help!! You must be hired by sony support team.. LOL

 

grettings from Mexico!!