account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Location based wifi not working as expected

Enthusiast
Message 11 of 14
840 Views
Message 11 of 14

Re: Location based wifi not working as expected


@T816B wrote:

Tomkay, guess what, my location based wifi works even with I turned OFF the Location. Glad to report it here.


Interesting. From my early tests, I seem to recall that it was necessary to have "Location" turned ON, but I could be wrong. I'm going to leave it ON for the time being because I'm not seeing any additional battery being used and it saves me turning it on manually whenever I use "Maps". The nice thing is that after I have used "Maps", GPS gets turned off automatically and consumes no more battery.

 

It took me a while to set up everything and I had to disable some services, but now I'm very happy with the battery life of my Z1 compact. From what I've seen the past days, my normal usage (some hours of screen time a day) and few, if any, calls, should get me through multiple days without a charge. I guess, I count as a "light" user.


@T816B wrote:

May I also ask you about Double Tap to Wake? Do you think this feature eats up battery life?


My Z1 compact does not support double tap to wake. I can only speculate, but it seems impossible to me that activating such a feature will not take some (however small) toll on the battery life. A good phone maximised for battery life will completely turn off power supply to any sensor that is not in use and in order to support double tap to wake, certain sensing capability will have to remain active.

 

This is why -- after a short period of experimentation -- I switched off the ability to use "OK Google" from every screen. Having the latter active implies that the microphone is monitored from every screen and that should cost more battery life than only using the microphone when prompted to do so. I currently don't need a 100% hands-free operation, so I turned the feature off in the hope that it will gain me a bit more battery life.

Rookie
Message 12 of 14
831 Views
Message 12 of 14

Re: Location based wifi not working as expected

I agree with you. Some sensors have to be on in order for the Double Tap to Wake to work. But my search on the internet shows that Sony does not have the battry drain issue for this feature, unlike Nokia (lots of reported cases).

 

I am going to try out by charging my phone to 100% before I go to sleep, and see what will the battery level is the next morning (try out with Double Tap to Wake On and Off).

Rookie
Message 13 of 14
807 Views
Message 13 of 14

Re: Location based wifi not working as expected

Ok, I tested the Double-Tap-to-Wake (DTTW) battery usage over the last 2 days.

 

I had the DTTW switched on before I went to sleep at 1130pm, the batter was at 79%. When I woke up at 7.00am the next day, the battery was at 64%, a drop of 15% over 7.5 hours.

 

The next day, I had the DTTW stiched off. The battery at 11.30pm was at 72% level. The next morning 7.00am, the battery was at 55%, s drop of 17%.

 

I did use the phones during the middle of the night on both nights, just to check out the stock markets.

 

From this test, I did not see a significant battery usage by switching on the DTTW.

 

 

Highlighted
Learner
Message 14 of 14
257 Views
Message 14 of 14

Re: Location based wifi not working as expected

Hi T816B, did it work on your phone? Is it alright now? I had my display replaced around 3 months ago. The phone came with factory settings. Before that, my location based wifi used to work so perfectly that I never checked for location or data settings. But after the factory reset and reinstalling of software, I'm having the same problem. It is turning off. But not turning on. Did you find any solution?