account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Headset Button changed behaviour (changes volume instead play/pause)

Highlighted
One time poster
Message 1 of 2
1,559 Views
Message 1 of 2

Headset Button changed behaviour (changes volume instead play/pause)

Hello Guys,

 

I have some trouble with my Xperia Z1 compact for some days now. When I plug in a headset, the play/pause button changes the volume instead of handling music player or calls. It behaves like volume keys. But curiously sometimes like Volume Up and another time (after reconnecting with the phone) it might change to Volume Down.

 

I have no clue, why the phone could change its behaviour out of the sudden. I am not aware of recent software updates or changes in apps, neither of unusual physical effects that could have damaged the hardware.

 

What I tried so far:

  • Tried another Headset: Same result with 3 Headphones, including the original ones that you get from Sony with the smart phone.
  • Checked and cleaned the headphone socket
  • Checking for software updates
  • Checking and deactivating Software like Smart Connect and Smart Key. Cleaned their cache and app data. And after that tried two third-party apps.
  • Restarted the device several times and tried the Save Mode as well
  • Also tried a hot fix by mapping the Volume keys of headsets simply to play/pause function with above mentioned apps. But that doesn’t work either?!
  • Cursed a lot

 

I have already read here several treads with similar problems, but they all concluded in incompatible hardware. But in my case it must be something with the phone, unless all three headsets broke as once. But is it a problem with software or the hardware? How can I find out? And most interesting for me: How can I fix this ******?

 

I hope you guys have an idea. Because I don’t want to miss any of my headset Buttons.

1 REPLY 1
One time poster
Message 2 of 2
1,355 Views
Message 2 of 2

Re: Headset Button changed behaviour (changes volume instead play/pause)

Hey, mine does the same. did you find anysolution at all? thanks


@KnUlf wrote:

Hello Guys,

 

I have some trouble with my Xperia Z1 compact for some days now. When I plug in a headset, the play/pause button changes the volume instead of handling music player or calls. It behaves like volume keys. But curiously sometimes like Volume Up and another time (after reconnecting with the phone) it might change to Volume Down.

 

I have no clue, why the phone could change its behaviour out of the sudden. I am not aware of recent software updates or changes in apps, neither of unusual physical effects that could have damaged the hardware.

 

What I tried so far:

  • Tried another Headset: Same result with 3 Headphones, including the original ones that you get from Sony with the smart phone.
  • Checked and cleaned the headphone socket
  • Checking for software updates
  • Checking and deactivating Software like Smart Connect and Smart Key. Cleaned their cache and app data. And after that tried two third-party apps.
  • Restarted the device several times and tried the Save Mode as well
  • Also tried a hot fix by mapping the Volume keys of headsets simply to play/pause function with above mentioned apps. But that doesn’t work either?!
  • Cursed a lot

 

I have already read here several treads with similar problems, but they all concluded in incompatible hardware. But in my case it must be something with the phone, unless all three headsets broke as once. But is it a problem with software or the hardware? How can I find out? And most interesting for me: How can I fix this ?

 

I hope you guys have an idea. Because I don’t want to miss any of my headset Buttons.