account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Exchange Email problem

Regular
Message 11 of 102
3,375 Views
Message 11 of 102

Re: Exchange Email problem

I am not sure the Sony rep understand the problem.

 

This is not (at least for the Zimbra and Mdaemon users) a Microsoft Exchange problem.

This is a Activesync problem and how its implemented by either Sony or in my case Altn.com with their Mdaemon software.

 

I have Xperia tablet, Xperia Z and Xperia Z1 connected to the system. Only the Z1 has a problem.

 

I have on the server restricted the Z1 to use ActiceSync protocol 12.1 instead of 14.1 and neither versions works with the Z1.

 

I am in contact with Mdaemons (altn.com) development team and have sent them a debug log of the Z1 connection when
this happens.

 

Before getting an anwer back regarding the debug log:

The maximum Email body size in Mdaemon is 0xFFFFFFFF … over 2 gigabytes! Which should be enough.

 

I will get back to this list when I get an answer back.

 

Doc

 

 

Sony Xperia Support
Message 12 of 102
3,443 Views
Message 12 of 102

Re: Exchange Email problem

It might be another problem and i would be happy to make another escalation but it would help to have an account that this happens with so that we can replicate the problem. Could you ask your IT-department to arrange a test account and send it to me in a PM?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

One time poster
Message 13 of 102
3,408 Views
Message 13 of 102

Re: Exchange Email problem

I have exactly the same problem. I also use Mdaemon with activesync. It is working perfectly on my old Samsung S3, Ipad etc., if the problem won´t be solved very soon I will need to go back to Samsung. My new Sony Xperia X1 is my first Sony smartphone and if it not soon will be solved it will also be my last.

 

If any of you finds a solution then please let me know. Thank you!

Sony Xperia Support
Message 14 of 102
3,399 Views
Message 14 of 102

Re: Exchange Email problem

I've now get a test account (thanks Fjeld) and i have forwarded this for further investigation. I will update the thread as soon as i have more information.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Regular
Message 15 of 102
3,316 Views
Message 15 of 102

Re: Exchange Email problem

For what its worth while we are waiting for a fix and are one of the users of 21595 Mdaemon servers around the world, http://www.securityspace.com/s_survey/data/man.201209/mxsurvey.html

And since I am the IT Admin where Sony has a test account now I can see that Sony is trying with one device, so

they havent forgotten us completely.

 

Doc

Regular
Message 16 of 102
3,275 Views
Message 16 of 102

Re: Exchange Email problem

For those that have the Z1 and still are having problems.. At least with Mdaemon server.

 

Contact your IT admin and tell him this:


Step 1:
Remove the account on the device and restart the phone.

Step 2: (server)
Go into the users Activesync folder and find airsync.ini and set ProtocolVersion=2.5

Like this:
DeviceType=SonyC6903
RemoteAddress=xxx.xxx.xxx.xxx
UserAgent=SonyC6903/4.2.2-EAS-1.4
ProtocolVersion=2.5

Step 3 (server)
Also go into Mobile device management Activesync/restrictions and add
SonyC6903/ to new restrictions Useragent and set it to protocol 2.5 and set device SonyC6903 and do the same.


Step 4
Then add the account and it should work. (of course on the next Z1's with problems only step 1,2 and 4 are necessary)

Doc

Regular
Message 17 of 102
3,123 Views
Message 17 of 102

Re: Exchange Email problem

I think they might have forgotten us. 

The latest update did not help...

 

 

Sony Xperia Support
Message 18 of 102
3,042 Views
Message 18 of 102

Re: Exchange Email problem

I just got more information and the cause of this is that the server does not fully comply with Microsofts specifications.

This issue is caused by the way in which the server responds to our request for fetching the email body. The request we are sending is strictly following Microsoft specifications for Exchange protocol. According to these specifications, and in order to have full support for S/MIME, we must form a request with the following option:
airsync:MIMESupport : Send MIME data for S/MIME messages only. Send regular body for all other messages. (see [MS_ASCMD] section 2.2.3.100.1)
The server (Mdaemon implementation used for testing) ignores this and it always responds with multipart/MIME message although a message should have a regular body when it is not a S/MIME message.

 

I recommend that you contact the server provider to see if they are aware of this issue.

 

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Commissioner
Message 19 of 102
3,022 Views
Message 19 of 102

Re: Exchange Email problem

not to say sony does everything right, but i use the active sync and exchange daily and have had no issues with the exchange server at work. Infact i much prefer this full fledged stock client that sony provides to even the standard client given by samsung.. that being said.. emoze to date has been one of the best clients i have used. 

Don't forget to give Kudos and / or mark the correct answer.
Message 20 of 102
3,015 Views
Message 20 of 102

Re: Exchange Email problem

Its fine with ALL other Android devices. I've tested the stock Android 4.2.2 Mail2apk and Exchange2.apk, they work also fine.

Now you say, you are right.

That means all others are faulty and only your implementation is right? Really??


Windows Mobile 6.0, 6.5, Windows Phone 7, 8 and 8.1, all iOS Versions and all other Android devices are working finewith z-push but only you are right...