account arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-down

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.


Error with MTP USB Drivers

Posts: 0

Error with MTP USB Drivers

My phone was working fine a while ago, PC Companion great too. However now I got a new PC all drivers in, no errors is a Intel i7, x64, USB 3.0 however I cannot reinstall the PC Companion or update my phone to the new software. It keeps crying because my PC cannot find MTP USB Driver. I try to manually install it usign the Device Manager>Choose a file from your computer It didn't worked! I've seems many posts talking about the same thing but no real answers so far, here are my screeshots, my phone is an Xperia arc with Android 2.3.3, I still haven't received the upgrade:

MTP error.png

I also manually downloaded the new version of PC Companion installed it but is not able to recognize my device software, I cannot downoad any features like the File Manager, keep saying that the app is not able to connect to an online server. My internet conection is ok, checked the application connection config, firewall, everything is ok, but still is not working_ Any thoughts? BTW this phone gets super slow I had to install ANdroid Task Manager app to control the usage of the cache memory and the overall running apps. The Sony Ericsson native apps are a pain in the butt they keep crashing, or failing. Dude this is a nightmare... please help!


Here's one other screenshot of the issue I installed the new PC Companion.

I went to Settings>Storage and I dismounted the SD card and reconnected the phone, this action fixed the MTP driver stuff,

but still when you connect the phone (without the SD Card mounted or with it) the software catches the Model and Serial but everything related to software is not acccessible, no File Manager download, no Contats Sync up, no nothing, raises>Application could not be installed exception

If you try to click where it says>Phone software update information not accessible then another windows pops up with the message>

PC Companion need to connect to an online server. Server not accesible...

MTP Issue 2.png

MTP error.png

Posts: 87,497
Registered: ‎2010-07-03

Re: Error with MTP USB Drivers

how about SUS

install it -> restart your PC -> turn off your firewall and antivirus -> run SUS and try again

Update Service (SUS)

Don't forget to mark the Correct Answers & Helpful Answers

"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Posts: 0

Re: Error with MTP USB Drivers

Here are the steps I took to fix the problem:

  1. As uliwooly said you have to download the latest SUS version in
  2. Download the latest PC Companion version at
  3. Install, reboot (if requested, i dind't have to do it)
  4. Turn off firewall and antivirus temporarily
  5. Unmount your SD card go to Settings>Storage
  6. Connect your phone to the PC using th eregular USB cable that comes with your phone
  7. Update the software
  8. Update your apps
  9. Replug your antivirus and firewall
  10. Mount your SD back

This is a workaroud, however the post is still a bug that should be fixed by the PC companion developers, That software has a bunch of gaps.

And please IMPROVE YOUR ERROR MESSAGES, put a code or something to make the diagnose easier.

Hope this helps,

One time poster
Posts: 11
Registered: ‎2012-03-10

Re: Error with MTP USB Drivers

I don't know if this can help anybody, but on my end the problems with the MTP driver could be solved by putting a smaller SD card in. With my 32 GB card the phone can't be accessed by PCC, with 2 - 8 GB it works flawless, with 16 GB it will work random.