account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Can't read Exchange mail body after 6.0.a.3.73 update

Unregistered user
Not applicable
Message 1 of 36
21,775 Views
Message 1 of 36

Can't read Exchange mail body after 6.0.a.3.73 update

After I update my Xperia S with the latest patch, I found the email body of my Exchange account can't be read.  The email body shows nothing for HTML mails & only the first line for plain text mails.  I've already tried removing my exchange account in my phone & add it again.  The problem is still there.  My mail server is MS Exchange 2007.   Any help is appreciated!

Regards

Cedric

35 REPLIES 35
Oracle
Message 2 of 36
2,200 Views
Message 2 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

I'll have to do some testing on this.

In the meantime, can you please try with a different app to see if it's working? Try with RoadSync and see if it works better.

Oracle
Message 3 of 36
2,200 Views
Message 3 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

OK, I was able to try this out quicker than I thought

I managed to grab hold of a colleague who's using Xperia S (6.0.A.3.73) with Exchange.

We are also running Exchange 2007 here at the office and everything is working fine with all kinds of e-mails. Both plain text and HTML work with no problems.

What do you think about this forum? Let us know by doing this short survey.

Unregistered user
Not applicable
Message 4 of 36
2,200 Views
Message 4 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

Thank you for your reply.  I've tried Roadsync & no problem to read the mail body.  However, RoadSync is a paid app & I expect my Xperia S works with Exchange natively.

I've already tried to reset my mobile & remove all user data but just no luck Slightly frowning Face

Is it possible that my problem do with any ActiveSync policy in Exchange server?

Thanks!

Oracle
Message 5 of 36
2,200 Views
Message 5 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

I suggest you try to run a software repair in PC Companion. Start the program and click on Support Zone > Start update > Repair software. Read the instructions that follows.

Let me know when you've done this.

Since we do not have the issue here I can only guess that something went wrong when you updated the phone. A repair of the software will hopefully sort it out.

What do you think about this forum? Let us know by doing this short survey.

Unregistered user
Not applicable
Message 6 of 36
2,200 Views
Message 6 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

Just finished repair & setup the Exchange account again.  The problem is still there.  There is no error in sync but when I open a email, the mail body is blank or just show 'converted from text --'.

Oracle
Message 7 of 36
2,200 Views
Message 7 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

Does this happen with ALL emails? Do you have a colleague with a similar or maybe even the same phone model? Can you try with a different account in this phone so we can rule out the possibility of your account being the issue?

Before you updated to .73, was everything working fine with Exchange?

Also please post your SI number and I will do my best to investigate further.

(This can be found behind the back cover, SI XXXX-XXXX).

Unregistered user
Not applicable
Message 8 of 36
2,200 Views
Message 8 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

It only happens to my Corporate emails.  My Gmail has no problem.  Some my colleagues are using other brands Android phones & they do not have this problem.  One of my colleague is using Xperia Arc & he has no problem too.  Actually, my last Xperia Neo V works with Exchange perfectly.  I just switch to Xperia S this week.  Let me try with another account when I back to office tomorrow.

I don't have this problem before .73 upgrade.

Should I post my SI number in public?

BTW, I've just setup another IMAP account in my phone & it can receive both HTML & plain text email with no problem.

Unregistered user
Not applicable
Message 9 of 36
2,200 Views
Message 9 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

Just leave you my SI number by private message. Thanks!

Unregistered user
Not applicable
Message 10 of 36
2,200 Views
Message 10 of 36

Re: Can't read Exchange mail body after 6.0.a.3.73 update

Just tried to setup another Exchange email account in my phone.  Same problem.  My colleagues do not have this problem with the same account in their Android phones.