account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Apprentice
Message 1 of 11
2,010 Views
Message 1 of 11

Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

On the 14th of Dec I received the latest update from Xperia.

Unfortunately, from that moment on I cannot make calls from my car.

There are 2 situation I can describe:

1. The phone will immediately connect to the Bluetooth of my radio and as soon I try to make a call and the call connects, the phone will drop the bluetooth connection with the radio.

2. The phone will not connect to the radio. I then manually ask for the connection, but then it won't keep it.

 

Before this update everything was working fine with my Audio system.

Please let me stay safe while driving.

While waiting for an answer... and hopefully a fix of this bug, I thank you for the attention

 

PS. I have already tried restarting phone, Audio system...

 

UPDATE 12.23.2015: It's been two days that the phone is running properly. I'll keep this post updated, should something change!

Merry Christmas!

10 REPLIES 10
Learner
Message 2 of 11
1,824 Views
Message 2 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Hi I have a z5 premium and alpine head unit and experience the exact same problem. Worked perfectly ok with my Xperia Z. Do you have a fix.
Learner
Message 3 of 11
1,820 Views
Message 3 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Will update the Bluetooth software in the Alpine INE-W940e head unit and update forum on if it works.
Seems straight forward, refer attached link:

http://www.alpine.com.au/showPage.php?pid=655
Learner
Message 4 of 11
1,815 Views
Message 4 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Updated the Alpine head unit software with the latest Bluetooth software from Alpine. The Bluetooth connectivity is intermittent then does not connect. Issue with phone.

Will test connection with Audi Q3. Bluetooth works with the Sony srs portable speaker.
Learner
Message 5 of 11
1,810 Views
Message 5 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Tested in 2013 Audi Q3 and it stayed connected. Alpine head unit is a INE-940EAU 2015 model.

Apprentice
Message 6 of 11
1,792 Views
Message 6 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

The first step is to make sure that the Alpine INE-W940E connected is compatible with the Bluetooth profiles supported by your Xperia Z5 Premium.


The compatible profiles are:

 

  • Advanced Audio Distribution Profile v1.2
  • Audio/Video Remote Control Profile v1.3
  • Device Identification Profile v1.3
  • Generic Access Profile
  • Generic Attribute Profile Client/Server over LE
  • General Audio/Video Distribution Profile v1.2
  • Handsfree Profile v1.6 (Wide band speech)
  • Headset Profile v1.2
  • HID over GATT Profile v1.0
  • Human Interface Device Profile, Host role v1.0
  • Messaging Access Profile v1.1
  • Object Push Profile v1.2
  • Personal Area Networking Profile v1.0
  • Phonebook Access Profile v1.1
  • Serial Port Profile v1.1
Apprentice
Message 7 of 11
1,787 Views
Message 7 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Car Head Unit INE-W940E Bluetooth Specification

 

BLUETOOTH Specification

  • Bluetooth V2.1+EDR

Output Power

  • +4 dBm Max. (Power class 2)

The compatable profiles are:

  • HFP (Hands-Free Profile)
  • OPP (Object Push Profile)
  • PBAP (Phone Book Access Profile)
  • A2DP (Advanced Audio Distribution Profile)
  • AVRCP (Audio/Video Remote Control Profile)
Highlighted
Apprentice
Message 8 of 11
1,783 Views
Message 8 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Will test Z5 Premum in safe mode

Apprentice
Message 9 of 11
1,769 Views
Message 9 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Booted in safe mode 

 

1) requested confirmation of code.

2) INE-940E confirmed paring.

3) Z5 continued trying to pair until timing out.

 

 

Apprentice
Message 10 of 11
1,737 Views
Message 10 of 11

Re: Bluetooth no longer working with Alpine receiver after update (10.7.A.0.228)

Updated to build number 224 and now 253 and still problems connecting.