account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Battery usage on WIFI always on 60%+

Highlighted
Learner
Message 1 of 7
1,564 Views
Message 1 of 7

Battery usage on WIFI always on 60%+

Good. I have a xperia m4 aqua . Android 6.0.1 . Everything is fine. but I see that the battery consumption is concentrated in WIFI . I see the wifi consumption is greater than 60% of the battery, and the trend continues to drain the battery.

Could you tell me it can be? . wifi settings switch between suspension and without suspension and battery consumption is focus in wifi.

Thank you so much.

6 REPLIES 6
Emperor
Message 2 of 7
1,563 Views
Message 2 of 7

Re: Battery usage on WIFI always on 60%+

@octavito00

 

probably third party apps that are causing this, check if you experience the same in >>> safe mode




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Genius
Message 3 of 7
1,528 Views
Message 3 of 7

Re: Battery usage on WIFI always on 60%+

Hi @octavito00

 

Were you able to recreate this while in safe mode as @uliwooly suggested? Does the same thing happen over mobile data as well?

 

I would suggest you wait until about 10% power remain and go to Settings > Battery > Press the battery and check your battery usage.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Learner
Message 4 of 7
1,484 Views
Message 4 of 7

Re: Battery usage on WIFI always on 60%+

Hi. Thanks for the info.@didrik & @uliwooly

I tell them that I discovered after several days happens with the wifi and it consumes so much battery.

When the equipment is in standby Wifi off. This happens whatever configuration you are using ( suspended , never , ever) . It turns off and then connects each time unlocking the phone. and in short use wifi permanently connecting and disconnecting battery consumes more than if it remains active . is a failure because it could set in x amount of time off and connect again to unlock the phone.

Sorry for the delay and my bad English

Genius
Message 5 of 7
1,464 Views
Message 5 of 7

Re: Battery usage on WIFI always on 60%+

@octavito00, how long would you say that your battery lasts? Did you check the battery usage to see what app is using the most power?

 

Was there any change if you reboot your phone to safe mode?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Learner
Message 6 of 7
1,455 Views
Message 6 of 7

Re: Battery usage on WIFI always on 60%+

Hi . @didrik

The battery lasts between 12 and 15 hours. depending use .

I have the stamina on mode programmed from 40 % battery .

In safe mode I did not solve the problem. the problem is that wifi is turned off in standby and turn the display lights wifi . and must be connected , search network, obtain IP and connect. in the previous version existed stamina clock , this version does not exist ?. Thank you for your attention , attached print

Screenshot_20160901-121907.png

Learner
Message 7 of 7
1,329 Views
Message 7 of 7

Re: Battery usage on WIFI always on 60%+

Hi all,

 

I suspect that this there is a problem with the software on how they report the battery usage. I did a clean install for 6.0.1, so there should not be any update related bug, but that is when the Wi-Fi becomes the highest usage since then. See below, the Wi-Fi used 71% of the battery consumed, the detail page shows 1570mAh, which is about 65% of M4 Aqua's 2400mAh battery, but my phone only consumed 30% since charged (90%-60%=30%), so where did the extra 35% comes from?

Screenshot_20160918-144446.png

Screenshot_20160918-144453.png

 

Before this, I have tried to turn off WI-Fi scanning in the location menu, and keep the Wi-Fi turn off throughout my sleep. But when I woke up the next day, the Wi-Fi consumption is still off the chart. So this is my take on this Wi-Fi consumption issue.