account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

5.1.1, problems with camera and notifications

Learner
Message 21 of 45
963 Views
Message 21 of 45

Re: 5.1.1. bug report

I'm experiencing very similar issues with Z1 Compact (D5503). The alarm application crashes having played the alarm sound only once. The issues arose after yesterday's update to 5.1.1. 

Trying to fix it, I've followed instructions from http://forums.androidcentral.com/google-nexus-4/466434-clock-alarms-stopped-working-lollipop.html

Namely, I disabled Google play services, rebooted to safe mode, wiped cache partition, enabled the services (then had to login again) and updated them. But it didn't help.

 

Thinking about a factory reset... but don't want to waste time reconfiguring the phone.

 

P.S.: Also have checked the camera: shutter sound is played only once, after taking a few shots the camera app freezes.

P.S.: I use stock firmware without root access and have updated via Wi-Fi.

Enthusiast
Message 22 of 45
942 Views
Message 22 of 45

Re: 5.1.1, problems with camera and notifications

Hi support team,
I have got 2 issues for camera (built-in) freezing after upgrading to Android 5.1.1
1.Freeze after press camera several times (already cleared cache of camera and restarted the phone) , it happens both Ultra Stamina Mode and normal mode so please refer the 2 screenshots https://app.box.com/s/8t40rx1phi4r51ct7msjrzbckxuycvjk.
2. When the camera app freezing then restarted the phone, I find that settings of "Data storage " option changes from SD card to "internal memory " always so please refer the link :https://app.box.com/s/wks11odntxrifvfttja5ljnscouvbx57
My info :model c6902, Android 5.1.1
Note :FACTORY RESET is not advisable to me
Thank
Enthusiast
Message 23 of 45
939 Views
Message 23 of 45

Re: 5.1.1, problems with camera and notifications

FYI :Xperia Z1,build no:14.6.A.0.368
Genius
Message 24 of 45
936 Views
Message 24 of 45

Re: 5.1.1. bug report

ok so I have been working at this for a few hours and have not solved the issue

 

I have been concentrating my effort on the camera issue, camera  takes one photo - on the second photo the shutter sound disappears - it will continue to take photos (without shutter sound) as long as I don't close it and if I close the camera it won't open again. 

 

1. safe mode makes no dfference

2. If I only take one photo and close the camera it will open and allow me to take another photo with shutter sound, I can continue to do this without issue taking one photo at a time.

3. If I try to take a 2nd photo without closing the camera the shutter sound disapears and the camera gives a not responding error

 

It is as though the sound files are being disrupted and held in a busy state if an attempt to use a 2nd time without shutting the app, this is likely similar to the ringtone not repeating (going silent) and the alarm issue - they all seem to be related to sound or audio access

 

I have also shut down processes and apps in an effort to restart the camera without a reboot but nothing works

 

so the only thing left now is an update repair using PCC and start fresh  

Genius
Message 25 of 45
931 Views
Message 25 of 45

Re: 5.1.1, problems with camera and notifications

RumRai7

 

did you update using PC Companion ?

Sony Xperia Support
Message 26 of 45
919 Views
Message 26 of 45

Re: 5.1.1, problems with camera and notifications

Would it be possible for you to send me log files from your phones when this has happend?

To do this:
Go to Settings > About phone > Build number, tap 7 times on the build number
Go back and select Developer options and turn on "USB debugging"
Restart the phone
Replicate the issue
Settings > Developer options, select "Take bug report". When the report is ready you'll get a notification that you can tap and share to for example Google Drive. Please send me a private message with a link to it.

If possible, please provide separate logs for the camera and alarm issue.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Highlighted
Genius
Message 27 of 45
908 Views
Message 27 of 45

Re: 5.1.1, problems with camera and notifications

will do, I'm trying something new to see if it works by deleteing system and data and doing a clean install of the 5.1.1 FW and see if the problem persists - if it does I will do as you suggest, this is all very time consuming lol

 

can I veiw the log - how would I do that ?

 

 

&&&&&&&&&&&&&& update

 

so after doing the above and flashing the rom onto a totally wiped phone the camera is now working, so I need to gradually build up all my apps settings etc and see how that goes and I still have root Slightly smiling Face

One time poster
Message 28 of 45
898 Views
Message 28 of 45

Re: 5.1.1, problems with camera and notifications

Hi,

Do any of you have a problem with the transmission of data after the update?

Learner
Message 29 of 45
876 Views
Message 29 of 45

Re: 5.1.1, problems with camera and notifications

Wi-Fi works normally. Haven't tested mobile data.


@wiewior wrote:

Hi,

Do any of you have a problem with the transmission of data after the update?


 

Enthusiast
Message 30 of 45
867 Views
Message 30 of 45

Re: 5.1.1, problems with camera and notifications

YES,I did.