account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

4g not working

Inhabitant
Message 11 of 14
86 Views
Message 11 of 14

Re: 4g not working

Yeah, thats what I thought, sent them a email so will be answers tomorrow Slightly smiling Face

Moderator
Message 12 of 14
84 Views
Message 12 of 14

Re: 4g not working

What network you on?


Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

Highlighted
Moderator
Message 13 of 14
82 Views
Message 13 of 14

Re: 4g not working

If it's anything like O2 in UK, it's because they only supply bare minimum speeds when EU roaming, even though you pay a daily premium, honestly it's really crud and won't change as long as the network only pays the EU network for minimal access.


Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

Inhabitant
Message 14 of 14
76 Views
Message 14 of 14

Re: 4g not working

Im from norway and i use "chili mobil" they use TELENOR internet thingy, out the year i get full speed 450mb/s, wich i get when im home. I pay like 34,31 £ a month for 10gb + EU.