account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Did you mean: 

Please read this if you considering unlocking the boot loader or rooting your phone.

Important information

Please note that you may void the warranty of your phone and/or any warranty from your operator if you unlock the boot loader. You should only unlock the boot loader of your phone if you are an advanced user with good knowledge of the technology and risks involved.

For more information go here

Please also note

The Sony Xperia support team will not be able provide any support, related to unlocking the boot loader or rooting your phone.

We also recommend you to read the below blogposts.

Best regards
Sony Xperia support team

Xperia XA2 h3113, TWRP/parted (resizing userdata) and black screen after reboot

Message 1 of 2
Message 1 of 2

Xperia XA2 h3113, TWRP/parted (resizing userdata) and black screen after reboot

So I think I've managed to hard-brick my XA2 while attempting to port some things to the AOSP8 source..


Device has unlocked bootloader and had ~15% battery charge.


After using parted to remove and recreate userdata and resizing it with resize2fs, after rebooting it all I got was the black screen and no LED.

When connecting to PC, no fastboot/flashmode is available, instead QUSB__BULK device pops up.


Tried almost any possible combination of power/volume keys for 3, 6 or 120 seconds, disconnecting/connecting cable before/after pressing the combinations - nothing helped yet.


Leaving for charging for 1-2 hours seems to have no effect - although I'm not sure how low-current charging mode is implemented on this chipset, and going to leave it overnight. The only visible change is that holding power button for ~10 second causes QUSB__BULK device to reconnect.


Any ideas/hints?  I don't believe that parted on mmcblk0 is enough to kill bootloader completely.

Message 2 of 2
Message 2 of 2

Re: Xperia XA2 h3113, TWRP/parted (resizing userdata) and black screen after reboot

Update on this: when a prepared* microsd was inserted, it started turning red/green led for 1/10th of a second when connected to charger / on holding power for 10 seconds.


*preparations: I've got another XA2 and a 32gb microsd on hand, 400 or so mb less than Xperia's storage, so dd would've not worked due to secondary GPT header not being copied. Instead, backed up partition table (sgdisk -b /dev/block/mmcblk0), deleted partition 79 (system_b), made another backup, restored it to mmcblk1, restored mmcblk0's partition 79 (sgdisk --load-backup), then copied every partition's data to sdcard with dd. (note for others attempting to recreate head.img method from other guide:  SBL/XBL partitions take at least 256mb, and gpt secondary header also needs to be copied/recreated)


Its still gets detected as QUSB__BULK (ade3), so left it on the charger to see what will happen next, maybe will try to connect to RX/TX at some point later to see whenever it attempts to boot off microsd at all.