account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Please read this if you considering unlocking the boot loader or rooting your phone.

Important information

Please note that you may void the warranty of your phone and/or any warranty from your operator if you unlock the boot loader. You should only unlock the boot loader of your phone if you are an advanced user with good knowledge of the technology and risks involved.

For more information go here http://unlockbootloader.sonymobile.com/

Please also note

The Sony Xperia support team will not be able provide any support, related to unlocking the boot loader or rooting your phone.

We also recommend you to read the below blogposts.

http://developer.sonymobile.com/wp/2011/03/29/unlocking-the-boot-loader-in-the-new-xperia%e2%84%a2-smartphones/

http://developer.sonymobile.com/wp/2011/04/14/option-to-unlock-the-boot-loader-now-available-for-advanced-developers/

http://developer.sonymobile.com/wp/2011/09/28/sony-ericsson-supports-independent-developers/

Best regards
Sony Xperia support team

Unable to flash any FTF in flash mode

One time poster
Message 1 of 2
1,332 Views
Message 1 of 2

Unable to flash any FTF in flash mode

I have a strange problem with with my XZ while trying to flash any ftf.
Here's the flashtool log;

25/037/2019 03:37:39 - INFO - Selected Bundle for Sony Xperia XZ(F8331). FW release : 41.3.A.2.192. Customization : Customized US
25/037/2019 03:37:39 - INFO - Preparing files for flashing
25/037/2019 03:37:40 - INFO - Please connect your device into flashmode.
25/037/2019 03:37:50 - INFO - Using Gordon gate drivers version 3.1.0.0
25/037/2019 03:37:51 - INFO - Opening device for R/W
25/037/2019 03:37:51 - INFO - Device ready for R/W.
25/037/2019 03:37:51 - INFO - Reading device information
25/037/2019 03:37:51 - INFO - Phone ready for flashmode operations.
25/037/2019 03:37:51 - INFO - Opening TA partition 2
25/037/2019 03:37:55 - INFO - Device connected in flash mode
25/057/2019 03:57:42 - INFO - Device disconnected

The strange thing is that the phone does not actually get disconnected, windows doesn't even play the disconnection sound and the green light signifying flash mode stays on.

I've tried flashing 2 different MM ftf files and 2 different Oreo files but it always stops at the same point. I cant use fastboot because my bootloader is still locked.
I tried repairing with xperia companion but it always fails with basically no information. I feel like I can still rescue the phone because i have flash mode, fastboot mode and when i power on, it shows the Sony logo and then "software update failed". Also, the phone shows up as SOMC flash device when plugged in in flash mode(if that helps). Pls what do I do from here?

1 REPLY 1
One time poster
Message 2 of 2
1,300 Views
Message 2 of 2

Re: Unable to flash any FTF in flash mode

I have xperia neo in which i am unable to use flash. whenever i try to use flash i enable flash mode but then the flash tool gtes stucks. what do i do? prepaidgiftbalance?