account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Please read this if you considering unlocking the boot loader or rooting your phone.

Important information

Please note that you may void the warranty of your phone and/or any warranty from your operator if you unlock the boot loader. You should only unlock the boot loader of your phone if you are an advanced user with good knowledge of the technology and risks involved.

For more information go here http://unlockbootloader.sonymobile.com/

Please also note

The Sony Xperia support team will not be able provide any support, related to unlocking the boot loader or rooting your phone.

We also recommend you to read the below blogposts.

http://developer.sonymobile.com/wp/2011/03/29/unlocking-the-boot-loader-in-the-new-xperia%e2%84%a2-smartphones/

http://developer.sonymobile.com/wp/2011/04/14/option-to-unlock-the-boot-loader-now-available-for-advanced-developers/

http://developer.sonymobile.com/wp/2011/09/28/sony-ericsson-supports-independent-developers/

Best regards
Sony Xperia support team

{ EMMA } Sony Flash tool for Xperia™ devices

Learner
Message 51 of 132
4,872 Views
Message 51 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Hello there, I happen to have a little problem with Emma, i guess.

Short story: Nabeel, do you happen to know wether there are any firmware releases in the emma repository that is publicly available for the Xperia Z Ultra?
After installing Emma (correctly, i may add, with the customization-file)

and connecting my Phone in flash-mode

(Phone LED light up green then red and then turns of, all quite fast)

emma tells me that there are no services available.

I am pretty sure that is false though,

as i used emma succesfully before, about half a year ago and there were services back then available.

Here is a screen-capture, maybe it helps:

Spoiler
Emma_problem_1.PNG

One last note about this: Hovering over the status-warning reads: Service execution was aborted

 

Hopefully you or maybe someone from the forums can help me here.

I really doubt that there are no services for the Ultra Z.

Forum Legend
Message 52 of 132
4,858 Views
Message 52 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

@tallarean The developer service is always available for all the phones that are supported by EMMA. 

 

From the screenshot you posted, I can see that your phone is connected on the second connector in emma. The first one is blank. 

It looks like a problem with the PC. Could you run emma after disabling anti-virus software if any and see if the problem remains. Also, do not use any other USB port on your computer while your phone is connected.

 

If nothing works, just give it a try on another PC. 

Will wait for the results.

_______________________________________________________________________
Discussion guidelines.
Message me or any other moderator to seek help regarding moderation.

Learner
Message 53 of 132
4,854 Views
Message 53 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Hey Nabeel,  thanks for the fast reply.

Sadly those tips won't work because I don't use any Anti-Virus Software (don't worry, I run Virtual machines).
Regarding a different Computer: I already tried that. I used my Notebook, running Windows 10, with the same problem.

It would be great if Emma were a bit more verbose, but I guess that's the limitation that comes with not having a devel-account.

 

Do you think it might be worth trying flashtool with an older android stock image and then update it ota?

 

Another thought: If push comes to shove, I am positive I can flash images using fastboot (thats how i got CM on there) and that works definitly. But I think all the images I've seen up till now are .ftf files. Any idea wether they can be unpacked for use with the flashboot way?

 

thanks, I appreciate your help.

 

edit: just so you know, I did try Emma on the native machine, not a virtual machine.

 

One time poster
Message 54 of 132
4,828 Views
Message 54 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

i have downloaded emma .after installation i copy the .ini file in installation folder.

then i start the app,after some time it shows "CONNECTION PROBLEM".

But i have working internet connection..

helppp meeeeeeeeeeeeeeee

Learner
Message 55 of 132
4,819 Views
Message 55 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Hey Trilo, could it be that you are behind a proxy?

Some internet providers and home administrators use those for caching and security reasons.

Try to ask your admin wether thats the case.

Should that not be the case, I'd check the Firewall (if any is used) wether it filters emma traffic.

After that, maybe your Anti-Virus Software that blocks traffic? If not AV, maybe the Windows internal security?

Rookie
Message 56 of 132
4,778 Views
Message 56 of 132

Re: [Q] Emma device support

Hi Nabeel:

 

"Emma gets to decide what to flash." - but what if it chooses incorrectly?  Can you set it up so that there is a choice? 

 

Here is my situation - I am working with an Xperia Ray ST18i.  It has installed gingerbread 2.3.4 which is 4.0.2.A.0.62.  Emma offers to re-flash the same version. 

However, there was an official Sony update [service] on this device type to ice cream sandwich 4.0.4, which was 4.1.B.0.587.  That's the one I need.  As the device is unlocked, I cannot get there with PC Companion. 

 

Can you alter (fix) the Emma database to [also] point to the correct version? 

 

Thank you

 

One time poster
Message 57 of 132
4,596 Views
Message 57 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Hi, I don´t know if this is the place to ask ( sorry if not) but this is my situation, the final task is to install the developer option for marshmallow for my E3 D2206, what i have done so far is Install emma and plugin my device image01.

But my device has been tempered, installed custom bootloader CWM and SuperSU for rooting my questions are:

1) it is possible to install the recovery for sony and remove CWM with Emma?

2) it is possible to install the marshmallow form Emma or should it be build from Github and loaded by Fastboot?

 

Thanks.

 

 

Emma01.png

image01.

Learner
Message 58 of 132
4,523 Views
Message 58 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

So, Update from me, regarding the (now not anymore) lack of "services" for my Ultra.

 

Well, after I couldn't find a way to flash my Device and it tucked it away for quite a while 

I was kinda bored and just charged it up, reinstalled emma and plugged it in.

Voila, suddenly there are two services! After installing the most recent one and checking it works I'm really happy.

 

But I really wonder why it suddenly works... I see two possible reasons:

1. Device ran out of energy and reset something. Somewhere.

2. There was an update to the repositories for the services. If thats the case, thank you, to who ever i have to thank for that!

 

Interestingly its actually a newer Version than I had befor my CM try. It's actually 5.1.1., for a Device thats reeeeaaaally old now,

so thank you, to everyone who worked on that.

 

One time poster
Message 59 of 132
6,395 Views
Message 59 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

i install totally emma  

and workin g everithing

but i csnt sing in

how can i sign in

i aredy create id pasword

when i can it use

One time poster
Message 60 of 132
4,443 Views
Message 60 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Hello,

Can we update to android M 6.0 after Flash with Emma ?

 

My phone is Z3 Compact (D5803), and build number is 23.4.A.1.200, but I don't see any available update...