account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Please read this if you considering unlocking the boot loader or rooting your phone.

Important information

Please note that you may void the warranty of your phone and/or any warranty from your operator if you unlock the boot loader. You should only unlock the boot loader of your phone if you are an advanced user with good knowledge of the technology and risks involved.

For more information go here http://unlockbootloader.sonymobile.com/

Please also note

The Sony Xperia support team will not be able provide any support, related to unlocking the boot loader or rooting your phone.

We also recommend you to read the below blogposts.

http://developer.sonymobile.com/wp/2011/03/29/unlocking-the-boot-loader-in-the-new-xperia%e2%84%a2-smartphones/

http://developer.sonymobile.com/wp/2011/04/14/option-to-unlock-the-boot-loader-now-available-for-advanced-developers/

http://developer.sonymobile.com/wp/2011/09/28/sony-ericsson-supports-independent-developers/

Best regards
Sony Xperia support team

{ EMMA } Sony Flash tool for Xperia™ devices

One time poster
Message 11 of 132
11,841 Views
Message 11 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Hi guys,

 

are there any more things needed?

 

I've followed the steps (including Customization.ini) but Emma can't recognize my Xperia Z1 Compact. 

The Google fastboot driver is installed.

It should be supported according to this list: http://developer.sonymobile.com/services/flash-tool/supported_phones/

 

Fastboot is working unter linux.

$ fastboot getvar product
product: D5503
finished. total time: 0.003s

 

lsusb gives me: Bus 004 Device 042: ID 0fce:0dde Sony Ericsson Mobile Communications AB Xperia Mini Pro Bootloader

 

Any help is appreciated

 

Thanks

Hauke

 

 

Learner
Message 12 of 132
11,822 Views
Message 12 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

hi my xperia c4 is boot loop and not supported by emma and flashtools . 

im not flash any ftf to my phone .why emma not support c4 e5333 

please help me thanks

Forum Legend
Message 13 of 132
11,793 Views
Message 13 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

@Hauke Is the bootloader of your phone unlocked ?

 

@sajad25 

Repair it using PC Companion

 

Perform a backup of everything as all the data on your phone (except SD card's) would be lost

Update / Repair your phone's software via PC Companion.
Download PC Companion and install it. Do not connect the phone to your computer unless you're asked to do so.

Launch PC Companion > Start Support Zone > Start Phone/ Tablet Software update > Select 
"Repair my Phone/ Tablet" > Follow the on-screen instructions it shows. 

_______________________________________________________________________
Discussion guidelines.
Message me or any other moderator to seek help regarding moderation.

Learner
Message 14 of 132
11,769 Views
Message 14 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

hi im using pc copanion by your detail  writing but get error 2003(sony update engine failure

Forum Legend
Message 15 of 132
11,692 Views
Message 15 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Looks like something on your PC is blocking the Sony Update engine from running on your computer, could you try another PC or disable firewall/ antivirus on your pc and try again ?

_______________________________________________________________________
Discussion guidelines.
Message me or any other moderator to seek help regarding moderation.

Rookie
Message 16 of 132
11,631 Views
Message 16 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

So the Emma program loads, I boot my phone in flash mode but it only displays the software I have on the phone already which is 5.0.2. It won't show the latest 5.1 update.

 

please help

One time poster
Message 17 of 132
11,609 Views
Message 17 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Folks, I am using Emma to flash a Sony Z1 Compact,

 

However, upon selecting the Z1 Compact KK 4.4.4 option (build 14.4.A.0.157) the result is that it flashes Lolipop!

 

Please can you check Emma is picking up the correct image file!

Ta

One time poster
Message 18 of 132
11,568 Views
Message 18 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

I have the same problem. Followed all instructions for installing Flashtool and how to connect, and phone is recognized by the Flashtool, but it does not make a difference if I choose 4.4.4 or 5.0.2 the latest OTA (14.5.A.0.270) stays installed somehow, even if flashtool is saying everything was working well... What might go wrong? Its downloading the files, it takes a few minutes to flash, but somehow its not working.

And yeah its unlocked (checked in service menu) no errors occur, no problems were shown, nothing, just saying working well but somehow now changes were made to the device. Somehow there is also no LED shining. Normally when using fastboot on Linux LED is blue, but holding volume keys down and then connect just made them ones green then red and then off while connecting to Win7 PC...

BUT i flashed CM boot.im from cm-12.1-20150815-NIGHTLY-amami.zip and booted into recovery from CM but then got stucked and got problems and were not able to boot anymore and so decided to go back to stock ROM. And again, doesn't Matter which ROM I choose, latest OTA got installed.

 

Also seems that Emma is not able to downgrade see http://ver.emma.extranet.sonyericsson.com/emma/documents/faq/#using_emma and then Q4 this would explain why I always get the latest Software installed, even if the listed version seems to be more outdated. So why are there all the old version listened?

 

And if you look in the right lower corrner and open the update details, its clearly shown, that its always the latest version .270 doesn't matter if you choose 4.4.4 or .240. This took me 1h to find out -.- Hope this all will help others before searching too much Slightly smiling Face

Rookie
Message 19 of 132
11,448 Views
Message 19 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

I have a problem with running Emma.

I've put the 'customization.ini' in the right folder. I've even made sure my Java is up to date. But I keep getting the following error message when I run Emma: 'Appliation error, please restart your client.'

After I click 'OK', Emma restarts on its own and I'm in an endless loop of errors and restarting until I delete the 'customization.ini' from the Emma folder. Then it stops giving the the error message and shows me the login screen.

I tried this on two different computers, one running Windows 10 (64-bit) and one on Windows 8.1 (32-bit) - I always get the same errors, no matter which machine I use.

Message 20 of 132
11,436 Views
Message 20 of 132

Re: { EMMA } Sony Flash tool for Xperia™ devices

Having same problem - Running Emma under Windows10 x64

 

Without the customisation.ini file emma starts up and presents the login screen.

 

When I copy customisation.ini to the Emma folder the login screen is not shown but after going through the motions of testing

network connections, checking for updates, synchronising product information it pops up a message box with title Application Terminating and a message of Application error, please restart your client.

 

Have tried a number of different compatability modes and running as administrator etc but nothing seems to help.

 

Also - when you click OK the application exits but then immediately re-launches itself and requires task manager to get rid of it.