account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Welcome to the Open Devices community!

This is where we discuss open source and development related questions on our Open Devices initiative.

Unable to boot AOSP.

Message 1 of 4
601 Views
Message 1 of 4

Unable to boot AOSP.

Hello,

 

I successfully followed the build guild and created the needed images, but I cannot get the device to boot. I verified that the images are for G8232 keyaki and the bootloader is unlocked. When I flash the images as the guide states and then flash the vendor files everything goes through with no issues. When the device is booted, I just get the Sony screen and rebooting every 3 or 4 minutes.

 

I was able to load up recovery and receive numerious errors stating the /cache partition was not found and could not be formatted. I have attempted to flash the created img file for cache with no success either.

 

I am sure I am missing something simple.

3 REPLIES 3
Highlighted
Developer World
Message 2 of 4
597 Views
Message 2 of 4

Re: Unable to boot AOSP.

Hi

you can always try to return back to Sony SW using flashtool (https://developer.sony.com/develop/open-devices/get-started/flash-tool/), then flash again the AOSP images

 

Did you flash the oem partition?

 

You can always try to flash the cache partition in case it got damaged with the following command

fastboot flash cache cache.img

 

 

Rookie
Message 3 of 4
583 Views
Message 3 of 4

Re: Unable to boot AOSP.

Hi.

 

Looks like you're missing several points during building AOSP. Here are some steps to make it better:

 

1. Install all of these in Ubuntu OS:

sudo apt install -y bc build-essential ccache curl g++-multilib gcc-multilib git gnupg gperf imagemagick lib32ncurses5-dev lib32readline-dev lib32z1-dev liblz4-tool libncurses5-dev libsdl1.2-dev libssl-dev libwxgtk3.0-dev libxml2 libxml2-utils lzop m4 openjdk-8-jdk pngcrush repo rsync schedtool squashfs-tools xsltproc zip zlib1g-dev bison gperf libxml2-utils make zlib1g-dev:i386 liblz4-tool libncurses5 lunch unzip clang

 

2. Put these lines in .bashrc and reload it:

 

export PATH=~/bin:$PATH
export LC_ALL=C
export LLVM_ENABLE_THREADS=1
export USE_CCACHE=1
export WITH_DEXPREOPT=true
export DISABLE_DEXPREOPT=false
export USE_CCACHE=1

3. Make sure that you're using actual Ubuntu OS installation rather than using Windows Subsystem For Linux.

Message 4 of 4
549 Views
Message 4 of 4

Re: Unable to boot AOSP.

Hey amirzaim,

 

I will follow your advice and try again. I actually tried the image you posted on XDA for the G8232 with the same result. I can flash the factory ftf with no issue and restore the phone, but custom images will not work.

 

I am sure I am missing something in the process.