account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Welcome to the Open Devices community!

This is where we discuss open source and development related questions on our Open Devices initiative.

Software binaries for AOSP Pie (Android 9.0) – Tone (don't work camera)

Learner
Message 1 of 6
2,122 Views
Message 1 of 6

Software binaries for AOSP Pie (Android 9.0) – Tone (don't work camera)

I try many AOSP installations (including official ones), but I get a camera for everyone that does not work. The camera and flashlight do not work (it is simply impossible to turn it on, as if it is not there). I’m seeing this problem with version 8 binary files. I’m doing something wrong, or is it a problem in odm?

My device is Xperia XZ

5 REPLIES 5
Apprentice
Message 2 of 6
2,075 Views
Message 2 of 6

Re: Software binaries for AOSP Pie (Android 9.0) – Tone (don't work camera)

Hi,

 

I can confirm that, have the same issues afterflashing latest tone oem to my own build for dora.

I own X Performance, hope that someone from SONY Team will see what's going on and those issues will be fixed fast.

Rookie
Message 3 of 6
2,009 Views
Message 3 of 6

Re: Software binaries for AOSP Pie (Android 9.0) – Tone (don't work camera)

I have the same problem with v8 and v7 binaries on kugo. Back to v6.

Developer World
Message 4 of 6
1,943 Views
Message 4 of 6

Re: Software binaries for AOSP Pie (Android 9.0) – Tone (don't work camera)

Hi,

 

the camera works fine when the latest vendor release is used with the latest version of AOSP (May)

 

Regards

Alin

Highlighted
Adviser
Message 5 of 6
865 Views
Message 5 of 6

Re: Software binaries for AOSP Pie (Android 9.0) – Tone (don't work camera)

Hi Alin,

 

i tested with 9.0.0_r41 but the issue still persists.

 

The Camera works after the reboot one time perfectly, if you close the camera app and restart it, everything does have a green tint. If you try it a third time, it just doesnt come up at all.

 

So the camera works only one single time after the reboot and thats it :/

 

I wasn't able to test with 9.0.0_r44 yet because this update causes my phone to constantly restart the whole UI and killing all open apps which makes it unusable for me

Developer World
Message 6 of 6
355 Views
Message 6 of 6

Re: Software binaries for AOSP Pie (Android 9.0) – Tone (don't work camera)

Hi

Please open a ticket on the bug tracker

https://github.com/sonyxperiadev/bug_tracker/

 

Before posting the bug 

-sync the code, build and wipe the userdata

- please try to use both AOSP camera and Open Camera for comparison

 

Regards

Alin