account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Welcome to the Open Devices community!

This is where we discuss open source and development related questions on our Open Devices initiative.

9.0-userdebug on H3113 XA2 hangs in SONY screen

SOLVED
Regular
Message 1 of 4
567 Views
Message 1 of 4

9.0-userdebug on H3113 XA2 hangs in SONY screen

Hi,

I flashed 9.0-userdebug on H3113 and device doesn't startup anymore (hang in SONY screen).

As a clean starting point I had flashed lastest official SW with EMMA tool before.

ADB is not available yet, so unfortunately there are no logs.

 

Additional info:

- repo sync was done yesterday 22.01.

- same flavor 9.0-userdebug was running w/o any problem round about 1 week ago

 

Do you have any advice?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Regular
Message 4 of 4
545 Views
Message 4 of 4

Re: 9.0-userdebug on H3113 XA2 hangs in SONY screen

Tried again with repo sync+update on 23.01. + SW_binaries_for_Xperia_Android_9.0_2.3.2_v5_nile.img

--> Issue seems to be fixed in the meanwhile

3 REPLIES 3
Visitor
Message 2 of 4
561 Views
Message 2 of 4

Re: 9.0-userdebug on H3113 XA2 hangs in SONY screen

Sony has released a new version of SW in Jan 22.

 

Make you really have the "latest" version of SW installed. ( ´・ᴗ・` )

 

I met the same problem on my X Performance(F8132).

 

Regular
Message 3 of 4
552 Views
Message 3 of 4

Re: 9.0-userdebug on H3113 XA2 hangs in SONY screen

I tried latest oem binary SW_binaries_for_Xperia_Android_9.0_2.3.2_v5_nile.img but this did not fix the issue.

However, this time I was able to get logs (logcat, dmesg), which I can provide if necessary.

Highlighted
Regular
Message 4 of 4
546 Views
Message 4 of 4

Re: 9.0-userdebug on H3113 XA2 hangs in SONY screen

Tried again with repo sync+update on 23.01. + SW_binaries_for_Xperia_Android_9.0_2.3.2_v5_nile.img

--> Issue seems to be fixed in the meanwhile