account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Welcome to the Open Devices community!

This is where we discuss open source and development related questions on our Open Devices initiative.

xperia x bootloop

Highlighted
Learner
Message 1 of 2
485 Views
Message 1 of 2

xperia x bootloop

i was working with  my xperia x and it suddenly died and stuck on sony logo on start . now it bootlooping after presiing poer button .
i installed sony companion and tried to repair but pressing power button and volume down key got me a green light and then started bootlooping . and nothing happened to sony companion .
i installed flashtool and it was the same trying for flash .
after pressing volume up and power key the phone turn into fastboot mode with blue solid light . falshtool says the phone connected in fastboot mode . i tried to flash kernel using kernel.sin file that i extarcted from ftf file but i got this error : target reported max download size of 536870912 bytes
sending 'boot' (20182 KB)...
OKAY [ 0.711s]
writing 'boot'...
FAILED (remote: Command not allowed)
finished. total time: 0.713s

and trying for system flash using system.sin nothing just happened .
i wonder if my problem is with software or hardware .
thanks

1 REPLY 1
Developer World
Message 2 of 2
108 Views
Message 2 of 2

Re: xperia x bootloop

Hi,

 

If your phone is locked please try to use PC Companion to recover your phone

IF your phone is unlocked please use EMMA to flash the latest available software

 

Regards

Alin