account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Welcome to the Open Devices community!

This is where we discuss open source and development related questions on our Open Devices initiative.

Xperia X Compact - AOSP Oreo - Stuck at Android logo

Learner
Message 1 of 6
2,007 Views
Message 1 of 6

Xperia X Compact - AOSP Oreo - Stuck at Android logo

I've compiled and flashed Oreo as per the instructions on a Xperia X Compact (F5321).

The build goes fine and I flash the boot, recovery, system, userdata and oem (downloaded separately) without problems.

 

When the system boots it goes past the bootloader and Sony logo, but is stuck on the Android boot animation (I've waited several hours).

 

I've tried building and flashing both 8.0 and 8.1 as per the instructions and I get the same result for both.

 

The device was flashed from FlashTool with the latest firmware (34.4.A.2.32) and was working fine running this.

5 REPLIES 5
Developer World
Message 2 of 6
1,938 Views
Message 2 of 6

Re: Xperia X Compact - AOSP Oreo - Stuck at Android logo

Hi,

 

I tried replicating the issue and I can not replicate it

 

1. do a new clean build

rm -r out

source build/envsetup.sh

lunch aosp_f5321-userdebug

make -j4

Please flash all partition (boot, recovery, userdata, cache, system, oem)

 

2. Please get the logs and post them here

while phone is at the android bootlogo

please conect it to the usb and type in on a shell

 

adb shell dmesg >dmesg

adb shell logcat >log

 

Regards

Alin

 

Learner
Message 3 of 6
1,897 Views
Message 3 of 6

Re: Xperia X Compact - AOSP Oreo - Stuck at Android logo

I have the same problem with xperia X F5121. I started with a fresh checkout of oreo 8.0 repo. (also tried oreo 8.1)  I did a fresh build and flashed these:

 

fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot flash system system.img
fastboot flash cache cache.img
fastboot flash userdata userdata.img
fastboot flash oem SW_binaries_for_Xperia_Android_8.0.5.7_r1_v10_loire.img

 

I captured the dmseg & log but they are too big to post here, but linked here: 

 

https://drive.google.com/open?id=1-1MDgJ0fLVgHvTr95TaEYdUsnZmsAnun

 

thanks

nt4
Learner
Message 4 of 6
1,889 Views
Message 4 of 6

Re: Xperia X Compact - AOSP Oreo - Stuck at Android logo

I have the same issue with the Xperia X F5121. I flashed the same binaries as described in the docs and built aosp_f5121-eng build instead of userdebug.

 

dmesg+ logcat

https://drive.google.com/file/d/1hVbXW2iKjr-b3eoDTvfjLwPJXvHFnEFN/view?usp=sharing

Highlighted
nt4
Learner
Message 5 of 6
1,869 Views
Message 5 of 6

Re: Xperia X Compact - AOSP Oreo - Stuck at Android logo

I found a workaround by building with the "userdebug" build variant. I'm able to boot the device now.

Developer World
Message 6 of 6
1,693 Views
Message 6 of 6

Re: Xperia X Compact - AOSP Oreo - Stuck at Android logo

Hi,

the eng variant has heavy debugging and should not be used

Regards

Alin