account arrowhead-down arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Welcome to the Open Devices community!

This is where we discuss open source and development related questions on our Open Devices initiative.

AOSP 7.1.1 - SIM-card not detected on Z3 Compact Tablet

Highlighted
Learner
Message 1 of 3
791 Views
Message 1 of 3

AOSP 7.1.1 - SIM-card not detected on Z3 Compact Tablet

Everything else seems to work OK, but SIM is not detected& Tablet status reports unknown baseband version.

I have built 7.1.1 twice with a week and did repo update. Same problem occurred each time.

 

In the log there are many errors like this:

02-03 05:52:10.264 3362 3362 F libc : CANNOT LINK EXECUTABLE "/system/vendor/bin/netmgrd": library "librmnetctl.so" not found
02-03 05:52:10.264 3362 3362 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 3362 (netmgrd)

 

There are a couple of other recent messages here referring to sim detection problem on 7.1.1.  Could that netmgrd-error be the cause of this and what to do?

2 REPLIES
Learner
Message 2 of 3
771 Views
Message 2 of 3

Re: AOSP 7.1.1 - SIM-card not detected on Z3 Compact Tablet

I managed to fix this "ibrmnetctl.so not found" - error by modifying  vendor/qcom/opensource/dataservices/Android.mk:

 

    #ifeq ($(PRODUCT_PLATFORM_SOD),true)
    ifneq ($(filter yukon rhine shinano kanuti kitakami loire tone yoshino,$(PRODUCT_PLATFORM)),)

 

which is same as previous github version.

 

But baseband version is still unknown and sim not detected.

 

 

Developer World
Message 3 of 3
683 Views
Message 3 of 3

Re: AOSP 7.1.1 - SIM-card not detected on Z3 Compact Tablet

Hi,

you have to:

- extract the contents of /etc/firmware from your device (flashed with a Sony SW)

- flash the device with your build

- copy the firmware onto your device (adb root && adb push etc/firmware/* /system/etc/firmware)

- reboot and enjoy

Regards

Alin