account arrowhead-down arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Welcome to the Open Devices community!

This is where we discuss open source and development related questions on our Open Devices initiative.

Lollipop (5.1) AOSP is not working on my Xperia E3 (2203)

Inhabitant
Message 1 of 3
1,751 Views
Message 1 of 3

Lollipop (5.1) AOSP is not working on my Xperia E3 (2203)

The current Lollipop (5.1) AOSP is not working on my Xperia E3 (2203).

I just followed the instruction (here). I was able to build and flash three image files (boot.img, system.img, userdata.img). However, after I flashed them on my device (Xperia E3 - D2203), the same thing happened.  I could only see the Sony logo as soon as I turned it on, then only black screen continued (LCD backlight is turned on). The same situation occured with AOSP 6 as well (see my previous question). Did I miss something?

 

Please let me know how to do it.

 

2 REPLIES 2
Developer World
Message 2 of 3
1,676 Views
Message 2 of 3

Re: Lollipop (5.1) AOSP is not working on my Xperia E3 (2203)

Hi

 

You need to update your bootloader using emma of the comunity flash tool since the one shipped with the device is too old

 

Regards

Alin

 

Inhabitant
Message 3 of 3
1,662 Views
Message 3 of 3

Re: Lollipop (5.1) AOSP is not working on my Xperia E3 (2203)

Thank you.

 

However, emma just shows an error messgae saying, "No matching services", although it can recognize the device.

I can't update my bootloader because of it. I think I have the same issue with this.

 

Please let me know what elas I can do.

 

Best,

Sung