Announcements

What do you think about our community?

Take a moment and share your thoughts around this community by doing this short survey.

Reply
One time poster
sunilkn006
Posts: 54
Registered: ‎2011-09-15

Xperia Pro Wifi keeps turning ON by itself

Hi, the wifi in my Xperia Pro keeps turning ON by itself although I do not turn it on. It won't turn off even if i try to turn it off. Please help.

Demigod
santam
Posts: 589
Registered: ‎2011-12-11

Re: Xperia Pro Wifi keeps turning ON by itself

Hi @sunikn006

try doing a settting reset.. go to MENU>SETTING>PRIVACY>SETTING RESET

and see if it's work...

*if not then try repairing your phone with SUS(sony update service)

here's the link..

http://www.sonymobile.com/global-en/tools/update-service/

please note* your mobile user data will be erased except SIM,SD CARD so backup your contacts..and others if needed:smileyhappy:

and keep us updated..:smileyhappy:

Don't forget to mark posts that answers the topic as Accepted Solution.
If you find any post helpful, press Kudos.
One time poster
sunilkn006
Posts: 54
Registered: ‎2011-09-15

Re: Xperia Pro Wifi keeps turning ON by itself

Hi, what settings will I be losing once I do setting reset. Can I make a backup of these settings?

Trustee
Markus
Posts: 2,840
Registered: ‎2010-09-20

Re: Xperia Pro Wifi keeps turning ON by itself

Do you have any 3rd party installed apps that might cause this? Any battery tweakers or data managers etc? It sounds like something in your phone is triggering this behavior.

The Wi-Fi should normally be easily turned on and off at Settings > Wireless & networks.

One time poster
sunilkn006
Posts: 54
Registered: ‎2011-09-15

Re: Xperia Pro Wifi keeps turning ON by itself

Hi, I don't use any battery tweakers. And about the data manager, I use the data monitor app provided by Sony Ericsson. I may have to reset my phone settings to factory default probably to get rid of this.

Trustee
Markus
Posts: 2,840
Registered: ‎2010-09-20

Re: Xperia Pro Wifi keeps turning ON by itself

If there's no 3rd party app installed that's set to activate Wi-Fi (for whatever reason) I suggest you run PC Companion and click your way to the repair software option at Support Zone > Start > Repair.

Remember to backup all data on the phone's internal storage since it will be lost during the repair. SIM card and SD card will not be touched.

One time poster
sunilkn006
Posts: 54
Registered: ‎2011-09-15

Re: Xperia Pro Wifi keeps turning ON by itself

Hi I made a setting reset. No use. Probably I'll have to repair my phone with SUS..

Demigod
santam
Posts: 589
Registered: ‎2011-12-11

Re: Xperia Pro Wifi keeps turning ON by itself

Ok...keep us updated after the SUS do you want to make backup of your contacts ? Because all user data will be deleted including contacts and applications let me know if you don't know...I'll help you out...as @Markus stated repair so probably it will work...keep me updated..:-D

Don't forget to mark posts that answers the topic as Accepted Solution.
If you find any post helpful, press Kudos.
One time poster
sunilkn006
Posts: 54
Registered: ‎2011-09-15

Re: Xperia Pro Wifi keeps turning ON by itself

Hi, I repaired my cell using PC companion. No use of repairing. My cell's wifi still keeps switching ON & OFF by itself. :smileysad:

Also, one day, I'd kept the cell in my pocket & after sometime I checked my cell, the phone had switched off by itself & had heated up a lot without using. I was unable to switch it on. I'd to forcibly remove battery & then switch it on. This has happen twice & my cell is just one month old. :smileysad:

One time poster
sunilkn006
Posts: 54
Registered: ‎2011-09-15

Re: Xperia Pro Wifi keeps turning ON by itself

Hi, I repaired my cell using PC companion. No use of repairing. My cell's wifi still keeps switching ON & OFF by itself. :smileysad:

Also, one day, I'd kept the cell in my pocket & after sometime I checked my cell, the phone had switched off by itself & had heated up a lot without using. I was unable to switch it on. I'd to forcibly remove battery & then switch it on. This has happen twice & my cell is just one month old. :smileysad: