Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Do you mean 
Announcements

What do you think about our community?

Take a moment and share your thoughts around this community by doing this short survey.

Reply
Adept
FolkCleric
Posts: 32
Registered: ‎2013-01-03

Xperia S network problem

When I've bought my Xperia S, I've noticed, that sometimes my phone signal is gone. First I thought, that it's network provider's problem, but after a while, I've noticed, that my parents and sister (they are using the same network provider) don't have that problem. The signal comes back only when I restart my phone. It really annoys me, because I can't get any messages or calls ant it drains my battery faster.

battery.png

I've tried to reinstall my phohe using PCC, but it didn't solve the problem.

Phone info.

Screenshot_2013-01-04-11-34-24.png

Adept
FolkCleric
Posts: 32
Registered: ‎2013-01-03

Re: Xperia S network problem

Any suggestions? This morning it happened again..

Screenshot_2013-01-05-.png

Adept
FolkCleric
Posts: 32
Registered: ‎2013-01-03

Re: Xperia S network problem

Anyone? I thought flagship devices had better support. :smileysad: My bad. :smileyplain:

One time poster
Smailchenko
Posts: 198
Registered: ‎2012-05-05

Re: Xperia S network problem

well i'm not an expert but i'll tell you my suggestions

1- Do a factory reset

2- Repair using Sony update service not Pc Companion

3- Do another factory reset

if that didn't help try to use a new simcard

Adept
FolkCleric
Posts: 32
Registered: ‎2013-01-03

Re: Xperia S network problem

1. Didn't help

2. Already tried.

3. It happens with any simcard.

Thanks for suggestions. :smileyhappy:

Adept
FolkCleric
Posts: 32
Registered: ‎2013-01-03

Re: Xperia S network problem

Well, I guess I'll have to wait for the Jelly Bean update and hope, that it will fix this problem. :smileysad:

Community Manager
Johan
Posts: 8,574
Registered: ‎2010-11-12

Re: Xperia S network problem

I suggest that you have your phone examined and fixed at an repair center if this happens using any SIM card. Contact your local support team for more info.

http://www.sonymobile.com/global-en/support/contact-us/contact-info/

Adept
FolkCleric
Posts: 32
Registered: ‎2013-01-03

Re: Xperia S network problem

So, finally I have received Jelly Bean update and guess what I have found this morning. No Service. :smileysad:

Had to reboot my phone again. My SIM is new and signal on other phones is great.

Android version: 4.1.2 Jelly Bean

Build number: 6.2.B.0.200

One time poster
liakoulee
Posts: 3
Registered: ‎2013-06-02

Re: Xperia S network problem

Ever since I updated to Jelly bean, the phone loses signal, it's like the antenna stops working all of a sudden. Doesn't seem to be a hardware issue as it didn't occur while the phone was on ICS...

One time poster
shlain66
Posts: 2
Registered: ‎2013-05-09

Re: Xperia S network problem

That is not encouraging news. The only reason I wanted JB was to fix the periodic loss of network.