Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Announcements

Accepted Solutions makes a difference!

Did you know that by clicking the Accept as Solution button You will help other people visiting the community to find their answer? Learn more.

Psst - What do you think about our community? Take a moment and share your thoughts around this community by doing this short survey.

Reply

Sony Xperia S + Linux (Ubuntu 64bit) File transfer

Rookie
Posts: 13
Registered: ‎2012-08-13

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

Don't try to fool people, it worked fine under gingerbread but SONY voluntary removed something just to push their PC companion use and satisfy Mickeysoft.

Highlighted
One time poster
Posts: 31
Registered: ‎2012-05-10

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

This issue is actually not Sonys fault. The connection problem to Linux is more because there are not many Linux dists supporting MTP out of the box.

Here is a guide how to connect Galaxy Nexus to Ubuntu.

http://www.omgubuntu.co.uk/2011/12/how-to-connect-your-android-ice-cream-sandwich-phone-to-ubuntu-fo...

But of course it would be nice if Sony released linux version of pc companion.

One time poster
Posts: 1
Registered: ‎2012-11-22

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

I too am experiencing USB data transmission problem with my Xperia P and Fedora 16. I was too impressed with the ICS's look and feel and its features. But this drawback of inability to transmit data using USB seems to be a real nuisance. Despite, Android having a Linux kernel, Sony not easily supporting USB data transmission is a typical case users may wish for another brand of phone. I like this phone for many of its features ; camera, video, sound etc. etc. are excellent. But what is the use

of keeping the photos and videos that you have unless you can transfer it to your laptop? I know that, this isn't a problem for Windows users.

But being a long time Linux user and booting into Windows, merely for data transmission is cumbersome and I hope many Linux users don't want.

I did some reserach and tried every possible way of transferring data to/from the phone, and finally wasn't successful. I tried bluetooth first. It wasn't pleasing at all. The pairing operation seems to be successful, and data transmission, particularly fairly big files seem to be started, but freezes in no time. I was successful in transmitting very small images from the Linux machine to the phone, but bot vice versa.

Then I hoped the only way to be the USB transmission, but, unfortunately phone file system was never detected, which I beleived should have been plug and play as you just mount any other storage media. Later I found that Android is using a so called MTP protocol, rather than the legacy USB protocol. Then a bit of a further searching revealed that many other poor Sony users are sufferring with the same decease. But certain medications are suggested, such as to install the libmtp library and did so. So there was a bit of a hope suddenly. Then came to know about mtpfs and installed with the source tarballs after resolving so many depedancies. No use.. Finally thought to give a try with gMTP and did install that with a great difficulty.

All of a sudden the file system showed up in gMTP and I thought that the difficulties I faced have paid off. But once again, when starting to transfer a file between the phone and the Linux machine, a deadly looking error message popped up saying, "Data transmission failed with the MTP device", and now I have given up all the attempts.

Sony itself has to do something, such as requests made by other users, like making a Linux version of PC Companion. I would prefer sony to release an update fixing any deficiencies related to USB and bluetooth data transmission in Linux environment.

If anybody has now found out a solution, please provide us with some details.  

Many thanks

One time poster
Posts: 1
Registered: ‎2012-11-18

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

I finally managed to get it work. Initially I installed gMTP and I made sure I had mtpfs installed too. I failed to connect the device to it several times. I disabled USB debugging and now, when I connect the device (to either a USB 2.0 or USB 3.0 port) it detects and automounts it. Even if I get some errors and the files on the device appear after 30 seconds, meh, it works. It also pops out an error, something about camera initialization, close it and it should work just fine. I use Linux Mint x64.

It looks like now there are no more errors. For the ones who are looking for the solution and do not have time to read:

1) Make sure you have gMTP and dependencies installed (mtpfs)

2) Disable USB debugging

3) Connect it to a USB 2.0 or 3.0 port

4) Your distro should automount it

5) Open your newly mounted device (LT26i)

6) Wait for it to load (avg. 30 seconds)

7) Close error messages if any

One time poster
Posts: 1
Registered: ‎2013-03-03

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

But I think Sony should do something about this otherwise most open source developers will not be buying your phones.It does not make sense that Sony is not supporting Linux...Android is Linux...why not support your own community but Windows?

Rookie
Posts: 3
Registered: ‎2013-09-01

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

money talk

One time poster
Posts: 1
Registered: ‎2013-10-05

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

wow. Now I am sooo disappointed in Sony. I thought we were finally rid of special tools and applications for our computers to be able to add content and extract pictures and other media. Just buy an Android phone...or so I thought. I have laughed at Apple products that need a Windows or Apple application to even start. Now this. It is so epically bad that I have to keep myself from hitting caps lock and leave it there.

 

Now - with that said. I'm on Ubuntu-12.04 LTS and installing mtsfs and gmtp didn't work out of the box. Will now try to update to the latest gmts and hope for the best. It didn't recognize the VID/PID combination of my Xperia pico.

 

I will not:

* buy a Windows license just to be able to get media from a phone

* buy a phone (sony or not) that tries to force me to use one or other computer OS

One time poster
Posts: 1
Registered: ‎2013-12-17

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

yea you have to switch it over in settings>xperia>usb connectivity>usb connection mode and then switch it from media transfer mode to mass storage mode and there ya are...im on linux mint 13 works like a charm...android version 4.2.2

One time poster
Posts: 1
Registered: ‎2014-02-23

Re: Sony Xperia S + Linux (Ubuntu 64bit) File transfer

[ Edited ]

On your Android settings go to the Xperia tab - enter - press connectivity- Press USB connection mode- select Maass Storage Mode [MSC]  plug your device into linux laptop USB and go from there. But you can access only sd card content - its ok for me.

Mint 16 (32bit) + Adroid 4.1.2. Xperia SP.

Thanks!