Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Announcements

What do you think about our community?

Take a moment and share your thoughts around this community by doing this short survey.

Reply
Anonymous(anon)
Posts: 0

xperia play not working

Hi everyone,

I was just hoping someone could help me out. I've had the xperia play for the last year and I've got to say I've not been impressed with it. It's really buggy and always seems to have one problem or another. First my facebook widget began interfering with my messages and when I would type a message it would select loads of random keys and type a load of gibberish. The thing is you can't uninstall it! So it just keeps happening.

Yesterday though I went to unlock the phone and it looked as though static was on the screen. Kind of like a telly with no signal. The thing is the phone is still working because I can hear text messages coming through. The screen will only work if I open the PlayStation section, that way the static goes? :smileyworried: I plugged the phone into my pc and ran pc companion which let me repair and reset the phone to factory default which has done nothing.

Like I say though the screen works in playstation mode but not normally so it's not the screen. It must be the phone :smileyworried:

Does anyone have any ideas? Any advice would be greatly appreciated

Thanks everyone

Sony Xperia Support
Sony Xperia Support
Sam
Posts: 6,811
Registered: ‎2011-04-11

Re: xperia play not working

Unfortunately in this case it appears you may have a hardware problem in which case I would have to advise that you have it sent in for repair.


What are your thoughts about this forum? Let us know by doing this short survey.