Reply
One time poster
Mads
Posts: 3
Registered: ‎2012-04-14

Xperia Arc S wifi problems

After upgradeing to Android 4.0 i cant connect to my WI-FI (WPA2-PSK). I can see my network, the phones states it gets an IP address and then just right after it goes into somekind of a loop : approves my logon, gets the IP ... then get throwed off and starting all over again. Before trying to logon to the network, it states that the signal is strong, but when in the so called loop, the phone suddenly claims that the signal is bad ?!?!

- Before the upgrade to Android 4.0, i had no problem whatsoever connecting to my WIFI.

- Our peripherals in our household, including my wifes XPeria Arc S, which not have been upgradded, hav no problems connecting to our WIFI.

- I have done a "reset to factory setting" without any luck

-  Also rebooted my Router, which has the latest firmware (Hawking HWR-54)

Any ideas??

/Mads Sabroe

Anonymous(anon)
Posts: 0

Re: Xperia Arc S wifi problems

Hi i  tried the samething on my router it did´t work   and i can´t make a call with my Ray my sons Arc s got the same problem

Anonymous(anon)
Posts: 0

Re: Xperia Arc S wifi problems

Correct answer.

I had the same problem after updating to android 4.0 ICS.

Then my friend followed these steps to fix this issue.

Go to

Menu -> Settings -> Backup & reset -> Settings reset -> confirm "reset phone"

It fixed my problem.

My data, apps & android 4.0 ICS were still the same. And  WiFi started connecting.

Please take caution before trying this.

Anonymous(anon)
Posts: 0

Re: Xperia Arc S wifi problems

I had the same issue, I enabled 'ANT Radio Service' and 'ANT Wireless State Notifier' and rebooted the phone. The problem was resovled.

One time poster
Husham.Sham
Posts: 4
Registered: ‎2012-04-29

Re: Xperia Arc S wifi problems

Sony Please Respond.

I've a Sony (Ericsson) Xperia Arc S (LT18i) smartphone.

My WiFi worked perfectly while I was on GB.

But as I updated to ICS 4.0.3, WiFi errors started showing.

After 4.0.3 update, my WiFi automatically disconnects me from the network after approximately in 10 - 40 seconds. But while connected data transwere was as normal as GB.

And when upgraded to 4.0.4 (first 4.0.4) update, WiFi connects and keeps its connection on, but data is not transfered. Data transfer only in first 2 or 3 seconds. It took me about 10 minutes to download 32KB via WiFi, and several reconnection to network.

And now I've updated to Sony's latest update for Arc S (i.e. ICS 4.0.4, Build 4.1.B.0.587).

But still the WiFi problem is not solved. Now WiFi is just in the state, when at 4.0.3. It connects and transfers data, but disconnects after 2 - 40 seconds.

Sony, please solve this "BUG" as we have to rely on WiFi for Internet.

Waiting for your reply.

One time poster
Afnan
Posts: 1
Registered: ‎2012-09-15

Re: Xperia Arc S wifi problems

The ICS release for sonyericson 2011 devices is hell.. The phone gets stuck, the speed is slow, the apps do not work like before and the major issue is the wifi signal problem... What is it??? Why the hell you are not providing us with a new software free from all bugs???

One time poster
Ammar
Posts: 1
Registered: ‎2012-09-17

Re: Xperia Arc S wifi problems

I have a similar problem since updating my Arc S to ISC.

My WiFi can no longer connect ot my Intellinet Access Point regardless how many times I changed the Access Point encryption, SSID, password, channel, etc.

The interesting thing is that when I switched to a N capable Access Point it connected straight away!

Couple of days ago I used Sony's Software Update Manager to upgrade to the latest LT18i_4.1.B.0.587 and I can attest that is is faster and snappier, but the WiFi problem still presists.

Another weird thing is that if I have ANT+ service running Before switching on my WiFi and connecting to the Access Point I'll never be able to use my WiFi unless I reboot the phone.

Now, Being a loyal Sony/Sony Ericsson/Sony user for the past 12 years I have to say that these issues must be ironed out Sony before we dump your phones and go the Samsung way or any other way.

NV
Newbie
NV
Posts: 2
Registered: ‎2013-09-13

Re: Xperia Arc S wifi problems

any one got problem solution..??


Ammar wrote:

I have a similar problem since updating my Arc S to ISC.

 

My WiFi can no longer connect ot my Intellinet Access Point regardless how many times I changed the Access Point encryption, SSID, password, channel, etc.

 

The interesting thing is that when I switched to a N capable Access Point it connected straight away!

 

Couple of days ago I used Sony's Software Update Manager to upgrade to the latest LT18i_4.1.B.0.587 and I can attest that is is faster and snappier, but the WiFi problem still presists.

 

Another weird thing is that if I have ANT+ service running Before switching on my WiFi and connecting to the Access Point I'll never be able to use my WiFi unless I reboot the phone.

 

Now, Being a loyal Sony/Sony Ericsson/Sony user for the past 12 years I have to say that these issues must be ironed out Sony before we dump your phones and go the Samsung way or any other way.




One time poster
jtnguyen
Posts: 1
Registered: 2 weeks ago

Re: Xperia Arc S wifi problems

i keep having this problem b ut somehow it comes and goes ...i think if you turn it on and off after a while it reset? or maybe reset you phone settings???